MUGIJIRU.JP

Webエンジニアの雑談ブログ

PHP

composerでPHPのバージョンを指定する

しょうもない話なのですが・・・開発端末A: PHP 7.0.1 開発端末B: PHP 7.0.11 開発端末C: PHP 7.1.8で共通のブランチに対して同時にプロジェクトの開発作業をしている状況で、 開発端末BのPHP 7.0.11でcomposer updateを実施し、composer.lockを更新しました…

(PHP4.0.6以上) 文字を特定のbyte数以内に収める

PHP

全角・半角文字の混在した文字列を特定のbyte数に収めるための便利な関数の紹介です。 公式Doc PHP: mb_strcut - Manual先頭から32byte以内で切り捨てる、みたいな処理を入れるなら下記のような感じになります。